Mobile network operator certifications

This section shows the nRF9160 modem firmware versions that are certified for operators who have their own certification programs. Most operators do not require other certifications than GCF or PTCRB. For the current status of GCF and PTCRB certifications, see nRF9160 certifications.

Operators requiring LwM2M carrier library

The Operators requiring LwM2M carrier library table shows compatibility between nRF Connect SDK and modem firmware versions for operators that require LwM2M carrier library. The LwM2M carrier library column shows the certified library that must be used for the given operator. The corresponding nRF Connect SDK column specifies the SDK version that contains the specific version of the LwM2M carrier library.

Note: It is mandatory to include the LwM2M carrier library in products that will be certified with a carrier listed in Operators requiring LwM2M carrier library.
Table 1. Operators requiring LwM2M carrier library
Operator Build code nRF9160 modem firmware version nRF Connect SDK LwM2M carrier library
LTE-M1 NB-IoT2
AT&T B0A 1.2.1 - 1.3.1 0.9.1
B0A

B1A

1.2.3 1.4.2

1.5.0

1.5.1

0.10.2
Verizon B0A 1.1.1 1.2.0 0.8.1
1.1.2 1.2.1 0.8.2
B0A

B1A

1.1.4 1.4.2

1.5.0

1.5.1

0.10.2

Operators not requiring LwM2M carrier library

The Operators not requiring LwM2M carrier library table shows compatibility between nRF Connect SDK and modem firmware versions for operators that do not require LwM2M carrier library.

Table 2. Operators not requiring LwM2M carrier library
Operator Build code nRF9160 modem firmware version
LTE-M1 NB-IoT2
AIS B0A - 1.1.1
Bell Canada B0A 1.2.0 -
B0A

B1A

1.2.3

1.3.0

China Telecom B1A - 1.1.4

1.3.0

Deutsche Telekom B0A

B1A

1.2.3 1.2.3
B1A 1.3.0 1.3.0
KDDI B0A

B1A

1.2.3 -
LG U+ B1A 1.2.3 -
SoftBank B1A 3 3
Telstra B0A 1.2.0 -
B1A 1.2.3
Telus B0A

B1A

1.2.3 -
B1A 1.3.0
T-Mobile US4 B0A

B1A

1.2.3 -
Vodafone B0A - 1.1.0
B1A 1.2.3
1 Available to only SIAA and SICA variants.
2 Available to only SIBA and SICA variants.
3 For details on SoftBank, contact Nordic's Regional Sales Manager in your area. For contact information, create a private support ticket on Nordic DevZone.
4 T-Mobile US will require LwM2M carrier library for future nRF9160 modem firmware versions.