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1 Introduction

The nRF Sniffer for Bluetooth LE is a useful tool for learning about and debugging Bluetooth Low Energy
(LE) applications. It provides a near real-time display of Bluetooth packets that are sent between a
selected Bluetooth Low Energy device and the device it is communicating with, even when the connection
is encrypted.

When developing a Bluetooth Low Energy product, knowing what happens over-the-air between devices
can help you identify and fix issues quickly.

On startup, the nRF Sniffer lists all nearby Bluetooth Low Energy devices that are advertising, providing
the Bluetooth address and address type, complete or shortened name, and Received Signal Strength
Indication (RSSI).
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2 Minimum requirements

Before you start, check that you have the required hardware and software.

Software requirements
• Supported operating systems:

• Windows 10
• 64-bit OS X/macOS 10.6 or later
• Linux (check the Wireshark prerequisites for version compatibility)

• Wireshark v3.4.7 or later
• Python v3.6 or later

Supported development kits and dongles
• nRF52840 DK (PCA10056)
• nRF52840 Dongle (PCA10059)
• nRF52833 DK (PCA10100)
• nRF52 DK (PCA10040)
• nRF51 DK (PCA10028)
• nRF51 Dongle (PCA10031)

Feature nRF51 DK nRF51
Dongle

nRF52 DK nRF52840
DK

nRF52840
Dongle

nRF52833
DK

LE Secure Connections No No Yes Yes Yes Yes

Max Data Packet Size 27 27 251 251 251 251

Max Advertising Packet
Size

37 37 255 255 255 255

Radio Fast Ramp-up No No Yes Yes Yes Yes

LE 2M Phy No No Yes Yes Yes Yes

LE Coded PHY No No No Yes Yes Yes

USB No No No Yes Yes Yes

Table 1: Supported features
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3 Installing the nRF Sniffer

The nRF Sniffer for Bluetooth LE software consists of firmware that is programmed onto a Development Kit
(DK) or dongle and a capture plugin for Wireshark that records and analyzes the detected data.

Before you start setting up the nRF Sniffer, check Minimum requirements on page 6.

Download nRF Sniffer for Bluetooth LE v4.x or later and extract the archive into a folder of your choice. In
the following sections, this folder is referred to as Sniffer_Software.

Then program the firmware to the DK or dongle, install the nRF Sniffer capture tool, and add a Wireshark
profile for the nRF Sniffer as described in the following sections.

3.1 Programming the nRF Sniffer firmware
You must connect a DK or dongle running the nRF Sniffer firmware to your computer to be able to use the
nRF Sniffer for Bluetooth LE.

See Supported development kits and dongles for a list of development kits and dongles that can run the
nRF Sniffer firmware.

There are various ways to program the nRF Sniffer firmware. The following instructions use nRF Connect
Programmer, but you can also use the command-line tool nrfjprog (which is part of the nRF Command
Line Tools).

To program your DK or dongle, complete the following steps:
1. Install nRF Connect Programmer.

See Installing the Programmer for instructions.
2. On macOS and Linux, install the SEGGER J-Link software.

It is available from SEGGER J-Link Software.

Note:  On Windows, the J-Link software is included in nRF Connect for Desktop, so you can skip
this step.

3. Locate the firmware HEX file for your DK or dongle.
All firmware HEX files are located in Sniffer_Software/hex/. Use the suitable file for your DK or
dongle:

Development kit/dongle Firmware file name

nRF52840 DK (PCA10056) sniffer_nrf52840dk_nrf52840_*.hex

nRF52840 Dongle (PCA10059) sniffer_nrf52840dongle_nrf52840_*.hex

nRF52 DK (PCA10040) sniffer_nrf52dk_nrf52832_*.hex

nRF51 DK (PCA10028) sniffer_nrf51dk_nrf51422_*.hex

nRF51 DK (PCA10031) sniffer_nrf51dongle_nrf51422_*.hex

Table 2: Firmware file names
4. Follow the instructions in Programming a Development Kit or the nRF51 Dongle or Programming the

nRF52840 Dongle to program the HEX file.
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Installing the nRF Sniffer

3.2 Installing Wireshark on Windows and macOS
The Wireshark installation procedure is the same for Windows and macOS.

To install Wireshark on Windows or macOS, complete the following steps:
1. Go to the Wireshark download page.
2. Click the release package for your operating system from the Stable Release list.

The download starts automatically.
3. Install the package.

Then install the nRF Sniffer capture plugin, as described in Installing the nRF Sniffer capture tool on page
8.

3.3 Installing Wireshark on Ubuntu Linux
Installing Wireshark on Ubuntu Linux requires setting up permissions for the current users by adding them
to specific user groups.

To install Wireshark on Ubuntu Linux:
1. Download the Wireshark standard package or the latest stable PPA for Ubuntu Linux distribution from

the Wireshark download page.
2. Install the package on your computer.
3. Answer yes when the installer asks you if non-superusers should be able to capture packets.

This ensures that packet capture is available to all users in the wireshark system group.
4. Add the correct user to the wireshark user group.

For example, type sudo usermod -a -G wireshark $USER.
5. Add the correct user to the dialout user group.

For example, type sudo usermod -a -G dialout $USER.
6. Restart your computer to apply the new user group settings.

Note:  Logging out might not be enough for changes to take effect.

Then install the nRF Sniffer capture plugin, as described in Installing the nRF Sniffer capture tool on page
8.

3.4 Installing the nRF Sniffer capture tool
The nRF Sniffer for Bluetooth LE software is installed as an external capture plugin in Wireshark.

To install the nRF Sniffer capture tool, complete the following steps:
1. Install the Python requirements:

a) Open a command window in the Sniffer_Software/extcap/ folder.
b) Install the Python dependencies listed in requirements.txt by doing one of the following:

• On Windows with Python launcher, type py -3 -m pip install -r
requirements.txt.

• On Windows without Python launcher, type python -m pip install -r
requirements.txt.

• On Linux or macOS, type python3 -m pip install -r requirements.txt.
a) Close the command window.
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Installing the nRF Sniffer

2. Copy the nRF Sniffer capture tool into Wireshark's folder for personal external capture plugins:
a) Open Wireshark.
b) Go to Help > About Wireshark (on Windows or Linux) or Wireshark > About Wireshark (on macOS).

c) Select the Folders tab.
d) Double-click the location for the Personal Extcap path to open this folder.

e) Copy the contents of the Sniffer_Software/extcap/ folder into this folder.

4393_261 9



Installing the nRF Sniffer

3. Make sure that the nRF Sniffer files can be run correctly:
a) Open a command window in Wireshark's folder for personal external capture plugins.
b) Run the nRF Sniffer tool to list available interfaces.

On Windows, type nrf_sniffer_ble.bat --extcap-interfaces. On macOS or Linux,
type ./nrf_sniffer_ble.sh --extcap-interfaces.
You should see a series of strings, similar to what is shown in the following screenshot.

c) If the previous step returned an error, verify that Python 3 is accessible.
On Windows, enter python --version. On macOS or Linux, enter python3. If the command
cannot be found or the version is wrong, make sure that Python v3.6 or later is in your path and
that it is the first Python version in the path.

d) For macOS or Linux: Verify that the nrf_sniffer_ble.sh file has the x permission.
If the x permission is missing, add it using chmod +x nrf_sniffer_ble.sh.

4. Enable the nRF Sniffer capture tool in Wireshark:
a) Refresh the interfaces in Wireshark by selecting Capture > Refresh Interfaces or pressing F5.

You should see that nRF Sniffer is displayed as one of the interfaces on the Figure 2: Wireshark
capture screen on page 14.

b) Select View > Interface Toolbars > nRF Sniffer for Bluetooth LE to enable the nRF Sniffer interface.

3.5 Adding a Wireshark profile for the nRF Sniffer
You can add a profile in Wireshark for displaying the data recorded by the nRF Sniffer for Bluetooth LE in a
convenient way.

To add the nRF Sniffer profile in Wireshark, complete the following steps:
1. Go to Help > About Wireshark (on Windows or Linux) or Wireshark > About Wireshark (on macOS).
2. Select the Folders tab.
3. Double-click the location for the Personal configuration to open this folder.
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Installing the nRF Sniffer

4. Copy the profile folder Sniffer_Software/Profile_nRF_Sniffer_Bluetooth_LE into
the profiles subfolder of this folder.

5. In Wireshark, select Edit > Configuration Profiles.
6. Select Profile_nRF_Sniffer_Bluetooth_LE and click OK.
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4 Running the nRF Sniffer

To start sniffing, place the DK or dongle that runs the nRF Sniffer for Bluetooth LE firmware between the
two devices that are communicating. Then open Wireshark and start recording packets.

Connect the DK or dongle to your computer and turn it on. Then place it between the Central and
Peripheral device that you want to sniff.

Note:  If you are using a DK with the nRF Universal Serial Bus (USB)  connector available, it is
recommended to use the nRF USB connector instead of the virtual COM port of the onboard
interface MCU. This is because the virtual COM port cannot match the higher Bluetooth LE
throughput of the nRF USB connector.

Figure 1: Hardware setup

When you open Wireshark, the Wireshark capture screen is displayed. It includes the Wireshark interface
for managing packets that are captured, the nRF Sniffer toolbar, and the hardware interfaces connected to
the nRF Sniffer.

Note:  If the nRF Sniffer toolbar is not visible, select View > Interface Toolbars > nRF Sniffer for
Bluetooth LE.

To start sniffing, double-click on the hardware interface (nRF Sniffer for Bluetooth LE COM17 in the
following figure).
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Running the nRF Sniffer

Figure 2: Wireshark capture screen

The following options are available from the capture screen in Wireshark:

RSSI filter
You can apply a RSSI filter on the packets that are being received. Only packets that match the filter
are displayed.

You must set the capture filter in the capture screen by using the keyword rssi. For example, the
filter rssi >= -70 only captures packets that have an RSSI greater than or equal to -70 dBm.

Figure 3: RSSI filter
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Running the nRF Sniffer

Interface options
Click the gear icon next to the interface to configure additional options for the nRF Sniffer for
Bluetooth LE.

Figure 4: Interface options

The following options are available:

Only advertising packets
Sniff only the advertising packets of the given device. When a new connection is established, the nRF
Sniffer ignores it.

Only legacy advertising packets
Sniff only the legacy advertising packets of the given device. The nRF Sniffer does not look for the
advertiser's device address in extended advertising packets in the auxiliary advertising packets.

Find scan response data
Follow scan requests and scan responses when sniffing all advertising devices. This option is useful
for finding the advertiser's name in the scan response data. You need an active scanner to generate
the scan requests to follow.

Find auxiliary pointer data
Follow the auxiliary pointer for additional data when sniffing all advertising devices. This option is
useful for finding the advertiser's address and name in the auxiliary advertising data.

Scan and follow devices on LE Coded PHY
Sniff on the LE Coded PHY when sniffing all advertising devices and a specific device. The nRF Sniffer
follows the connection on any PHY it uses. To sniff on both LE 1M PHY and LE Coded PHY at the same
time, use multiple sniffers.
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5 nRF Sniffer usage

Once the nRF Sniffer for Bluetooth LE is running, it reports advertisements and lists nearby devices in the
Device List. The software interface has several commands for controlling the operating mode of the nRF
Sniffer.

Note:  The nRF Sniffer might not pick up all connect requests and does not always pick up on a
connection. In such cases, reconnect and try sniffing again. If you do not see any activity in your
Wireshark console, see Troubleshooting on page 26.

The nRF Sniffer has two modes of operation:

1. Listen on all advertising channels to pick up as many packets as possible from as many devices as
possible. This is the default mode.

2. Follow one particular device and try to catch all packets sent to or from this particular device. This
mode catches all:

• Advertisements and Scan Responses sent from the device
• Scan Requests and Connect Requests sent to the device
• Packets in the connection sent between the two devices in the connection

The software interface provides commands and options that control the nRF Sniffer operation.

Figure 5: nRF Sniffer software interface

Hardware interface
This list shows the available hardware interfaces. If you have more than one DK or dongle with the
nRF Sniffer firmware connected, you can choose which one to control with the toolbar. To use several
hardware interfaces at the same time, see Capturing from multiple hardware interfaces on page
18.

Device list
This list shows nearby devices that are advertising. When you start sniffing, All advertising devices
is selected. Choose a device from the list to sniff that specific device. When you select a different
device while in a connection, the current connection is no longer sniffed.

If the device that you want to sniff is not found by the sniffer, you can add it to the list manually. See
Add LE Address on page 17.

A device can also be selected from the list by providing the LE address manually. See Follow LE
Address on page 17.

If the device is privacy-enabled and the LE address is unknown, you can select Follow IRK and enter
the IRK. See IRK on page 17.
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nRF Sniffer usage

Input key and value
Use this field to provide the nRF Sniffer with input information that cannot be captured from air-
traffic alone. To do so, select the input key from the drop-down menu and enter the corresponding
value in the input field.

The following input keys are available:

Legacy Passkey
If your device asks you to provide your passkey, type the 6-digit passkey in the passkey text field
and press Enter. Then enter the passkey into the device.

Legacy OOB data
If your device uses a legacy pairing procedure with a 16-byte Out of Band (OOB) key, provide it
in hexadecimal format (starting with 0x, big endian). You must do this before the device enters
encryption. If the entered key is shorter than 16 bytes, it is padded with zeros in front.

Legacy LTK
If your device has an existing bond using a legacy Long Term Key (LTK), provide it in hexadecimal
format (starting with 0x, big endian). You must do this before the device enters encryption. If the
entered key is shorter than 16 bytes, it is padded with zeros in front.

SC LTK
If your device has an existing bond using an LE Secure Connections LTK, provide it in
hexadecimal format (starting with 0x, big endian). You must do this before the device enters
encryption. If the entered key is shorter than 16 bytes, it is padded with zeros in front.

SC Private Key
If your device uses LE Secure Connections pairing and neither of the devices is in debug mode
(using the Debug private key), provide the 32-byte Diffie-Hellman private key of your device in
hexadecimal format (starting with 0x, big endian). You must do this before the device starts the
pairing procedure. If the entered key is shorter than 32 bytes, it is padded with zeros in front.

IRK
If your device is privacy-enabled, the IRK is needed to continue to follow the device when
it changes its LE address. You should provide it in hexadecimal format (starting with 0x, big
endian). You must do this before the device enters encryption. If the entered key is shorter than
16 bytes, it is padded with zeros in front. When selecting a device that can be resolved with
the IRK, the sniffer continues to follow any LE addresses that also resolves with the IRK. If the
current LE address of the device is unknown, the device can be followed by selecting Follow IRK
in the device list.

Add LE Address
If the device that you want to sniff is not currently advertising and therefore was not discovered,
use this field to add its LE address to the device list. Input the full 6-byte LE address, separating
each byte with a colon, and append the address type ("public" or "random"). For example:
57:25:b0:81:eb:e5 random

Note:  If you add a device while capturing is stopped, the device does not show up in the
device list until you start capturing.

Follow LE Address
If the device list is long, use this field to select the LE address in the device list. Input the full 6-
byte LE address, separating each byte with a colon, and append the address type ("public" or
"random"). For example: 57:25:b0:81:eb:e5 random
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Note:  If you follow a device while capturing is stopped, the device is not selected until
you start capturing.

See Sniffing the pairing procedure of a connection on page 23 for more information about
providing the security credentials.

Advertising hop sequence
You can change the order in which the nRF Sniffer switches advertising channels when following a
device. Define the order with comma-separated channel numbers, for example, 37,38,39. Press
Enter when done.

With the default configuration, the nRF Sniffer waits for a packet on channel 37. After it receives a
packet on channel 37, it transitions to sniffing on channel 38. When it receives a packet on channel
38, it transitions to sniffing on channel 39. When it receives a packet on channel 39, it starts sniffing
on channel 37, and repeats the operation.

Clear button
Click this button to remove all entries in the device list and start scanning for new devices. This
button is active only when capturing is ongoing.

Defaults button
Click this button to remove all entries in the device list and set all configuration options to their
default values. This button is active only when no capturing is ongoing.

Help button
Click this button to open the documentation.

Log button
Click this button to display the debug log and information about the nRF Sniffer version. Check this
log if you encounter any issues, and include the information when reporting issues.

5.1 Capturing from multiple hardware interfaces
You can capture packets from several hardware interfaces/devices simultaneously.

Note:  On Windows, this feature is available in Wireshark v3.0.7 and v3.2.0 and later. If you are
using an older version of Wireshark, you must run one instance of Wireshark for each nRF Sniffer
hardware attached to the computer. Select only one hardware interface in each of the Wireshark
instances.

To capture from multiple hardware interfaces simultaneously, select the hardware interfaces in the
capture screen and click Start Capturing packets.
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Figure 6: Select multiple hardware interfaces

The captured data contains the interface identifier used by Wireshark to identify the capture interface
(frame.interface_id) and the hardware identifier for the DK or dongle running the nRF Sniffer firmware
(nordic_ble.board_id).

Figure 7: Data capture from multiple hardware interfaces

5.2 Inspecting captured data
All Bluetooth Low Energy packets detected by the Sniffer for Bluetooth LE are passed to Wireshark, where
they are wrapped in a header containing useful meta-information not present in the Bluetooth Low Energy
packet itself. Wireshark dissects the packets and separates the actual packet from the meta-information.
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When you browse captured packets, select a packet in the packet list to show the breakdown of that
packet in the packet details pane. The bytes of the packet are shown in the packet bytes pane. Click a
value in the details to highlight it among the bytes, or click on the bytes to highlight it in the details.

Figure 8: Wireshark interface

To view the display filter for any field, click a value in the packet details pane. The display filter is shown in
the bottom left corner.
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Figure 9: Wireshark display filter

Use display filters to display a chosen packet subset. Most filters are based on the values of the packets,
such as length or access address. The filter expressions use Boolean operators (&& || == != !). To
construct a filter, click Expression in the filtering bar. See the following table for some examples.

Display filter Description

btle.length != 0 Filter that displays only packets where the length field of the Bluetooth
Low Energy packet is not zero, meaning it hides empty data packets.

btle.advertising_address Filter that displays only packets that have an advertising address
(advertising packets).

btle Protocol filter that displays all Bluetooth Low Energy packets.

btatt, btsmp, btl2cap Protocol filters for ATT, SMP, and L2CAP packets, respectively.

nordic_ble.channel < 37 Filter that displays only packets received on the data channels.

Table 3: Display filtering

The following tips can help when inspecting your data:
• Turn any field in the packet details pane into a column. To do so:

a) Right-click the value in the packet details.
b) Click Apply as Column.
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• Apply a value as a filter to, for example, see only operations affecting a particular handle. To filter
packets that have a specific value for some field:
a) Right-click the value in the packet details.
b) Click Apply as Filter.
c) Click Selected.

• Save a set of captured packets to be able to look at them later. To do so:
a) Click the Stop button to stop capturing packets.
b) Click File > Save As to save all packets, or click File > Export Specified Packets to save a selection of

packets.
• Clear the packet list and restart a capture by clicking the Restart button.

See the documentation on the Wireshark website for more information.
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6 Common sniffing actions

The nRF Sniffer for Bluetooth LE can help you explore and debug Bluetooth Low Energy communication in
a number of typical scenarios.

6.1 Sniffing advertisements from all nearby devices
Use the nRF Sniffer for Bluetooth LE to see advertisements from all nearby devices.

1. Run the nRF Sniffer (if not already running).
2. Ensure that All advertising devices is selected in the device list.

6.2 Sniffing advertisement packets involving a single
Peripheral
Use the nRF Sniffer for Bluetooth LE to see advertisement packets, scan requests, and scan responses to
and from a single device.

1. Run the nRF Sniffer (if not already running).
2. Select your device from the device list.

6.3 Sniffing a connection involving a single Peripheral
Use the nRF Sniffer for Bluetooth LE to sniff a connection between a specific Peripheral and a Central.

1. Run the nRF Sniffer (if not already running).
2. Select your device from the device list.
3. Connect the Central to the Peripheral.

6.4 Sniffing the pairing procedure of a connection
Use the nRF Sniffer for Bluetooth to sniff an encrypted connection between paired devices by sniffing the
pairing procedure.

Note:  If the DK or dongle running the nRF Sniffer firmware is reset, stored bond information is lost.

1. Run the nRF Sniffer (if not already running).
2. Select your device from the device list.
3. Enter the credentials for pairing. The procedure depends on the type of encryption.

• For connections that use legacy pairing with Just Works:

a. Initiate pairing between the devices if it does not happen automatically.

No further action is required.
• For connections that use legacy pairing with a passkey:

a. Initiate pairing between the devices if it does not happen automatically.
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Common sniffing actions

b. Select Legacy Passkey as input key and type the 6-digit passkey that is displayed on either the
Central or the Peripheral into the input field in Wireshark.

c. Press Enter.
d. Enter the passkey into the other device.

• For connections that use legacy pairing with OOB:

a. Before the devices initiate pairing, select Legacy OOB data as input key and type the OOB key in
big-endian, hexadecimal format with a leading "0x" into the input field in Wireshark.

b. Press Enter.
c. Connect the Central to the Peripheral.
d. Initiate pairing between the devices if it does not happen automatically.

• For connections that use LE Secure Connections in debug mode:

a. Enable Secure Connections debug mode on one or both of the devices.
b. Initiate pairing between the devices if it does not happen automatically.

In debug mode, the connection uses the debug keys specified in the Bluetooth Core Specification.
The nRF Sniffer uses the same keys to decrypt the encrypted packets.

• For connections that use LE Secure Connections with a private key:

a. Before the devices initiate pairing, select SC Private Key as input key and type the 32-byte Diffie-
Hellman private key of your device in big-endian, hexadecimal format with a leading "0x" into
the input field in Wireshark.

b. Initiate pairing between the devices if it does not happen automatically.

6.5 Sniffing a connection between bonded devices
Use the nRF Sniffer for Bluetooth to sniff an encrypted connection between bonded devices. If the nRF
Sniffer has previously successfully sniffed the pairing procedure, it remembers the LTK needed to decrypt
the connection. Otherwise, you must provide the LTK.

1. Run the nRF Sniffer (if not already running).
2. Select your device from the device list.
3. Enter the LTK for the bond.

• For connections that have an existing legacy bond, select Legacy LTK as input key and type
the legacy LTK key in big-endian, hexadecimal format with a leading "0x" into the input field in
Wireshark.

• For connections that have an existing LE Secure Connections bond, select SC LTK as input key and
type the LE Secure Connections LTK key in big-endian, hexadecimal format with a leading "0x" into
the input field in Wireshark.

4. Initiate encryption between the devices (pairing is not performed when a bond exists).

6.6 Sniffing advertisement packets involving a privacy-
enabled Peripheral
Use the nRF Sniffer for Bluetooth LE to see advertisement packets, scan requests, and scan responses
to and from a single privacy-enabled device. If the nRF Sniffer has previously successfully sniffed the
pairing procedure, it remembers the IRK needed to resolve the identity of the device. Otherwise, you must
provide the IRK.

1. Run the nRF Sniffer (if not already running).
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Common sniffing actions

2. Enter the IRK for the device. In Wireshark, select IRK as the input key and type the IRK in big-endian,
hexadecimal format with a leading 0x into the input field.

3. Select your device or Follow IRK from the device list.

6.7 Sniffing advertisement packets involving a Periodic
Advertiser
Use the nRF Sniffer for Bluetooth LE to see periodic advertise data from a Periodic Advertiser. If the
advertiser has periodic advertising sync information, the sniffer follows the periodic advertising train.

1. Run the nRF Sniffer (if not already running).
2. Select your device from the device list.
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7 Troubleshooting

If you have problems installing or using the nRF Sniffer for Bluetooth LE, see the following sections for
troubleshooting information.

The nRF Sniffer for Bluetooth LE is not listed in the Wireshark interface
Check that the hardware is set up correctly:

1. Ensure that the DK or dongle has been enumerated on USB and that the drivers are loaded.
2. Ensure that the firmware HEX file has been programmed.
3. Reset the hardware by unplugging the hardware, waiting 5 seconds, and plugging it back in.
4. Check that all Python dependencies have been installed. If multiple Python installations are present,

Wireshark might be using a different version than the one present in the user environment.
5. Check the sniffer log file log.txt for error messages.

• On Windows: %APPDATA%/Nordic Nordic Semiconductor/Sniffer/logs
• On Linux and macOS: /tmp/logs/

If these steps do not help, verify that you have installed the nRF Sniffer capture tool correctly and that the
Python script located in the extcap folder can be run, as described in Installing the nRF Sniffer capture tool
on page 8.

The nRF Sniffer for Bluetooth LE does not show up as a toolbar
Make sure that you enabled the nRF Sniffer interface toolbar.

To do so, click View > Interface Toolbars > nRF Sniffer for Bluetooth LE.

The nRF Sniffer for Bluetooth LE does not receive packets
When programming the nRF Sniffer firmware, make sure to use the latest SEGGER J-Link software. If you
used an older version, update your J-Link and program the firmware again.

The nRF Sniffer for Bluetooth LE does not receive packets on Windows
On Windows, COM port numbers higher than 199 are not supported. If the COM port number is COM200
or higher, rename the COM port on Windows to a COM port number that is COM199 or lower. To do so,
complete the following steps:

1. Open the Device Manager and click Ports (COM & LPT).
2. Right-click on your COM port and click Properties.
3. In Properties, go to the Port Settings tab and click Advanced.
4. Change the COM port number by clicking the COM port number drop-down and selecting a COM port

that is less than 200. Select a COM port number that is not in the list of devices currently attached to
your computer. These are listed in the Device Manager under Ports (COM & LPT).

5. Click OK and accept the changes when asked "Do you want to continue".

The nRF Sniffer for Bluetooth LE occasionally works but appears unstable
Make sure that you are using the correct software versions as specified in the prerequisites and that you
have installed the Python requirements.

When programming the nRF Sniffer firmware, make sure to use the latest SEGGER J-Link software. If you
used an older version, update your J-Link and program the firmware again.

If the problem persists, force J-Link to use flow control in the serial connection:
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1. Open JLink.exe (Windows) or JLinkexe (macOS/Linux) in the installation folder of the required J-
Link version.

2. Enter sethwfc force.
3. Exit the JLink software.

Packets are displayed incorrectly
Verify that the NORDIC_BLE protocol is enabled in Wireshark. To do so, click  Analyze > Enabled Protocols
and verify that the NORDIC_BLE protocol is selected.

Verify that a stable release of Wireshark is used. Development and user build versions are not supported.
For example, v3.0.7 and v3.2.0 are stable versions of Wireshark, as indicated by the second number being
an even number. Version 3.1.x is a development version of Wireshark, indicated by the second number
being an odd number.
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Glossary
Development Kit (DK)

A hardware development platform used for application development.

Long Term Key (LTK)
A key that is stored by both devices after the Bluetooth Low Energy pairing procedure has
establishing a bond. The Long Term Key is either distributed by the peripheral device (when using
legacy pairing) or derived from a Diffie-Hellman exchange (when using LE Secure Connections). The
key is stored in both devices and is used to encrypt connections between the two devices.

Out of Band (OOB)
A communication channel that is outside of the defined activity. For example, in Bluetooth Low
Energy, Out of Band pairing can be used to share encryption keys or authentication data using a
different communication channel (such as NFC).

Received Signal Strength Indication (RSSI)
An indication of the power of a received radio signal.

Universal Serial Bus (USB)
An industry standard that establishes specifications for cables and connectors and protocols for
connection, communication, and power supply between computers, peripheral devices, and other
computers.

Wireshark
A free software tool that captures wireless traffic and reproduces it in a readable format. It is a
cross-platform network protocol analyzer that can be used to view, analyze, and troubleshoot
packets sent over a data network.
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Acronyms and abbreviations
These acronyms and abbreviations are used in this document.

DK
Development Kit

LTK
Long Term Key

OOB
Out of Band

RSSI
Received Signal Strength Indication

USB
Universal Serial Bus
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Legal notices
By using this documentation you agree to our terms and conditions of use. Nordic Semiconductor may
change these terms and conditions at any time without notice.

Liability disclaimer
Nordic Semiconductor ASA reserves the right to make changes without further notice to the product to
improve reliability, function, or design. Nordic Semiconductor ASA does not assume any liability arising out
of the application or use of any product or circuits described herein.

Nordic Semiconductor ASA does not give any representations or warranties, expressed or implied, as to
the accuracy or completeness of such information and shall have no liability for the consequences of use
of such information. If there are any discrepancies, ambiguities or conflicts in Nordic Semiconductor’s
documentation, the Product Specification prevails.

Nordic Semiconductor ASA reserves the right to make corrections, enhancements, and other changes to
this document without notice.

Life support applications
Nordic Semiconductor products are not designed for use in life support appliances, devices, or systems
where malfunction of these products can reasonably be expected to result in personal injury.

Nordic Semiconductor ASA customers using or selling these products for use in such applications do so
at their own risk and agree to fully indemnify Nordic Semiconductor ASA for any damages resulting from
such improper use or sale.

RoHS and REACH statement
Complete hazardous substance reports, material composition reports and latest version of Nordic's REACH
statement can be found on our website www.nordicsemi.com.

Trademarks
All trademarks, service marks, trade names, product names, and logos appearing in this documentation
are the property of their respective owners.

Copyright notice
© 2022 Nordic Semiconductor ASA. All rights are reserved. Reproduction in whole or in part is prohibited
without the prior written permission of the copyright holder.
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