[88] WDT: Increased current consumption when configured to pause in System ON idle

This anomaly applies to IC Rev. Engineering A, build codes QFAA-AA0, QFAA-AC0, CGAA-AA0.

Symptoms

Using the mode where watchdog is paused in CPU Idle, the current consumption jumps from 3 µA to 400 µA.

Conditions

When we enable WDT with the CONFIG option to pause when CPU sleeps:
NRF_WDT->CONFIG = (WDT_CONFIG_SLEEP_Pause<<WDT_CONFIG_SLEEP_Pos);

Consequences

Reduced battery life

Workaround

Do not use mode where WDT is paused when CPU sleeps


Documentation feedback | Developer Zone | Subscribe | Updated 2016-07-05